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FrameMaker Template for www.designers-guide.org Submissions Guidelines and Suggestions
1 Guidelines and Suggestions
The Designer’s Guide website is dedicated to helping analog, RF, and mixed-signal
design engineers, particularly in the area of simulation and modeling. Any submissions
in these areas will be considered for publication. However, the focus is on giving practi-
cal and non-obvious advice to designers. 

To increase the chance of publication, a submission should be well-written. Thus it
should be clear, with a simple and direct presentation style. It should be free of gram-
matical and spelling errors. It should offer something of substantial practical value to
practicing designers. In addition, the material presented should neither trivial nor widely
known.

One should first present general principles before diving into specifics. This is particu-
larly important for anything where the specifics might go out of date. Do not just give a
recipe of how to do something, explain why. Doing so makes it more likely that the
readers will be able use the ideas presented in your paper even if their situation does not
exactly fit what you anticipated. Be liberal with your use of examples, and if appropri-
ate, submit them as well for inclusion with your paper.

Finally, commercial products can be mentioned when it serves to enhance the material,
but you must strive to be even handed and stop short of promoting products.

1.1 Target Audience

The target audience consists primarily analog, RF and mixed-signal circuit designers.

1.2 Updates

Papers should not be published on www.designers-guide.org until they are complete.
Thus, they should self contained, reviewed for errors, and the authors should be very
confident in their accuracy. However, one of the benefits of publishing on the web is
that documents can be easily updated. If you make corrections or improvements to a
paper that you had previously submitted successfully, please resubmit it with the
updates.

2 Use of This Template
We are trying to promote a common look to the documents published on www.design-
ers-guide.org, so you should try to use the paragraph and font styles that are available
with this template without modification. You can add your own styles or overrides if
necessary to do things we did not anticipate, but please keep them to a minimum.

3 The First Page
The title is entered first, try to keep it short. The headers on the subsequent pages are
keyed to the Title paragraph styles, so they should not be used anywhere else. Do not
place carriage returns directly in the title. Instead, to manually control the line breaking
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Paragraphs FrameMaker Template for www.designers-guide.org Submissions
in the title, insert shift returns. In other words, hold down the shift key while pressing
the carriage return (or enter) key.

The title is followed by the author or author list. With multiple authors, place each on its
own line. If desired, you can give their affiliations at the bottom of the page.

Next is the version number and date. Start with a version number of one, and simply
increment it by one each time the document changes is a meaningful way. Do not incre-
ment the version number if you correct minor errors (spelling, grammar, etc.), but do
increment it if you are either adding or changing the actual content. Change the date
whenever you increment the version number.

Next up is the summary. Use it to briefly describe the contents of the paper. In particu-
lar, describe what the reader can expect to gain by reading it. Try to keep it short, a few
paragraphs at the most.

At the bottom of the first page is the author and document information and the license
agreement. In this section, do not change the “Last updated” sentence. It contains a vari-
able that is automatically updated whenever a change is made to the document. This
date is different from the date next to the version number if any minor changes have
been made to the document. Replace the E-mail address with your own, and add any
comments you feel are appropriate about your affiliation or the publishing history of
this paper. Do not modify the licensing agreement, it must be the same for all papers on
the Designer’s Guide site.

3.1 Copyright Notice

Replace my name with yours in the copyright notice. To do so, change the Copyright
Owner variable using Special → Variable. Select Copyright Owner and click on Edit
Definition, change my name to yours, and then click on Change, Done, and Done.

You are the copyright owner, which means you retain the right to publish the work
wherever you like. Here at www.designers-guide.org we neither request nor desire you
to exclusively publish your work with us. The idea is to share information, and the more
exposure you can get for it, the more likely it will get to the person that needs it. How-
ever, by publishing on www.designers-guide.org, you agree to allow us to distribute the
paper under our license agreement, which is given at the bottom of the first page. 

4 Paragraphs
Choose section and subsection titles so that they fit on one line. In addition, they must
fit without conflicting with the paper title in the header at the top of the page.

Paragraphs are all given short unique abreviations as a prefix in to their names. This
makes easy to select them using only the keyboard. To do so, type the F9 key, then type
the prefix and then type return. Doing so will tag the current paragraph with the desired
tag. For example,

bo↵

would convert a paragraph to the bo Body style.

F9
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FrameMaker Template for www.designers-guide.org Submissions Paragraphs
The template provides a variety of paragraph styles to choose from. Use h1 Heading1 to
introduce new major sections, such as this section on paragraphs. h1n Heading1 NoNum
is used for sections at the end that are not numbered, like the sections for references or
acknowledgements. h2 Heading2 is used to introduce sub-sections. An example of h2
Heading2 is ...

4.1 Example of ‘h2 Heading2’

There are two more lesser forms of section heads, the first being h3 Heading3.

4.1.1 Example of ‘h3 Heading3’

The h3 Heading3 section heads do not have numbers and so should not be cross-refer-
enced and will not appear in the table of contents.

Example of ‘hr HeadingRunIn’. The least of the section heads it hr HeadingRunIn. As
you can see, it is a run-in paragraph, meaning that it embeds itself at the beginning of
the succeeding paragraph.

If you were to use one or more appendices, they would follow the normal sections and
precede the bibliography. For appendices, use a1 Appendix1 in lieu of h1 Heading1, a2
Appendix2 in lieu of h2 Heading2, and a3 Appendix3 in lieu of h3 Heading3. For run-in
heads, continue to use hr HeadingRunIn in appendices.

All headings should set in title case, meaning that all words will be capitalized. The only
exceptions are words such as a, of, the, and, etc. if they are not the first word in the title.

The basic paragraph style for most of the text is bo Body. However, there are some spe-
cialty paragraphs. You can create bulleted lists using the bu Bulleted and bs Bulleted-
Sub. Bulleted points can be continued using the in Indented and i2 Indented2
paragraphs. For example,
• This would be a point.
• This would be another point.

This would be the continuation of the second point.
• This would be a third point.

- This is a subpoint.
This would be the continuation of the subpoint.

You should not cross-reference items in a bulleted list. Instead, use a numbered list. The
first item in the list should use a paragraph style of n1 Numbered1. Subsequent items
would use nu Numbered. For example, ...
1. This is the first item.
2. This is the second item.

This is the continuation of the second item.
3. This is the third item.

a. This is a sub item.
b. This is another sub item.

This is a continuation of the subitem.
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The com Comment paragraph style is provided for you to use to make notes to yourself.
There should be no paragraphs that use the Comment style in the final version. Since it
will not be in the final version of your document, feel free to change it as you see fit.

4.2 Font Families

The document largely uses two basic font families. The serif font is Times and the sans-
serif font is Helvetica. These font families may also be referred to as TimesNewRoman
and Arial. If your computer does not have the Times and Helvetica font families, you
may switch the paragraph styles to use TimesNewRoman and Arial, though usually this
mapping is done automatically for you by Framemaker.

5 Equations
To enter a stand alone equation, insert a blank line and set the paragraph style to eq
Equation. This centers the equation and gives it a number that you can later refer to. If
you do not do this, any equations you add will be inserted in line.

To insert the equation, bring up the equation palette by clicking on the Σ to the right.
Then choose Equations → New Medium Equation (you can use the short cut of esc mm).
You can poke through the equation editor to create your equation. One thing that is help-
ful to know is that you use the space bar to select portions of the equation. The more
times you press it, the more of the equation you select. This is particularly helpful to
know when you are trying to get the parentheses right. Superscripts and subscripts are
under the Operators portion of the palette, but you can add superscripts using ^, and
subscripts with ctrl _. From a typographic perspective, it is important to remember that
variables are italicized while units, labels, functions, etc. are not. Thus, use vn if n repre-
sents a label, such as if were an abbreviation for noise, and vn if n represents a variable,
such as an index. Use StartString and EndString on the Symbols portion of the palette to
create non-italicized labels. Also remember that it is important to not use multicharacter
variable names, like Fc. Framemaker will typeset is as if it were two separate single
character variable names, and the user will often be confused. For example, consider the
expression . In this case it is better to use single characeter variable names with
subscripts, such as Fc. Generally, any word or word fragments that are acting as labels
should non-italicized subscripts, such as the “max” in Imax. To enter text into an equa-
tion, like the “max” in Imax, surround the text with quotes. For example, to enter Imax
type

I ctrl shift _“max”↵

When describing behavioral models, it is often useful to encorporate a parameter of a
behavioral model into an equation. For example, imagine giving the equation for an
amplifier with the gain being given by the parameter gain. To include this parameter
into an equation, one would again use the quotes to enter the name as text, and this time
you would go back and apply a font format to put it in the desired style, as follows

(1)

In this example, “gain ” was entered as text and then then the Code format was applied
to it from the font catalog. Notice that an extra space was include in the text to achieve
proper spacing from subsequent variables or operators.

4kTFcR

vout gain vin=
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When giving numbers with units, it is best to put a non-breaking space between the
number and the units, for example 10 pF. The non-breaking space is entered using cntl
◊, where ◊ represents a space. Finally, do not use asterixes, dots, or crosses to represent
multiplication. So it should be , not , , or gm*ro.

FrameMaker initially gives you plenty of room to build your equation, but you should
“shrink-wrap” your equation before moving on. The short cut for this is esc mp. When
editing an equation it is helpful to un-shrink-wrap the equation before operating on it,
the shortcut for this is esc me. Here is an example of how an equation should look when
you are done. Be sure to add the proper punctuation, as in

. (2)

If you are familiar latex, you might want to use FrameMaker’s ability to accept latex
style mathematics. For example, to create , I inserted an equation and then typed
\log↵ x. Be sure to type the carriage return after latex code to get FrameMaker to accept
it.

5.1 More Equations

I’ve heard many people say that equations are a weak point for FrameMaker, particu-
larly relative to LaTeX. While it is true that aesthetically FrameMaker’s equations are
not up to those typeset by LaTeX, particularly the superscripts and subscripts on sum-
mations and integrals, if you take advantage of the many short cuts, entering equations
can be done as efficiently, and you get the benefit of a WYSIWYG environment. I won’t
explain all of the shortcuts, but I will give you an example that illustrates the point.
Hopefully it is enough to get you started.

Consider the equation

. (3)

If ◊ represents pressing the space bar, and ↵ represents a pressing return, then this equa-
tion can be entered with the following sequence of keystrokes (try it).

esc mm x(t◊◊◊=a(\alpha↵cos\omega↵ ctrl shift _1◊◊t◊◊◊◊+\beta↵cos\omega↵ ctrl shift
_2◊◊t

It may seem odd just looking at it in this way, but if you try it out I think you will find
that it becomes fairly natural in relatively short order. 

Another thing about equations that is non-obvious is how to break equations over multi-
ple lines. FrameMaker does have a line-break feature in the equation editor, but I have
never found it to be satisfactory. Instead, I generally break the equations into sub-equa-
tions as follows:

 + (4)

 +

.

gmro gm ro⋅ gm ro×

C v( ) dq v( )
dv

--------------=

xlog

x t( ) a α ω1tcos β ω2tcos+( )=

x t( ) a α ω1tcos β ω2tcos+( )=

c α3

4
------⎝

⎛ 3 ω1tcos 3ω1tcos+( ) 3α2β
2

------------- 1 2ω1tcos+( ) ω2tcos+

3αβ2

2
------------- ω1t 1 2ω2tcos+( )cos β3

4
----- 3 ω2tcos 3ω2tcos+( )+ ⎠

⎞
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Floating Objects FrameMaker Template for www.designers-guide.org Submissions
I’ve done several things to make this work and look right. First I broke the equation into
three separate equations, each on their own line. FrameMaker naturally balances paren-
theses within an equation, so I explicitly used a unbalanced left parenthesis in the sec-
ond sub-equation and an unbalanced right parenthesis in the third. Be sure to select
enough of the expression before adding the unbalanced parenthesis so that FrameMaker
can determine how big to make the parenthesis. For example, on the last equation, I
selected the whole sub-equation before adding the unbalanced right parenthesis to
assure that it used a parenthesis that was large enough to cover the tall fractions.
FrameMaker will also not end and an equation with a binary arithmetic operator (such
as +), so I pulled those outside the sub-equations. 

I placed the first sub-equation on a line that used an emf EquationMultFirst paragraph
format. This format includes an equation number and left justifies the equation with an
indent. Using a left justified equation will reduce the amount of re-positioning of the
subsequent equations I would have to do when I edit the first. This paragraph format
also adds no space below the paragraph so that the sub-equations are not too far away.
All the subsequent sub-equations except the last, which is just one in this case, are
placed on a line that uses the emm EquationMultMiddle format. This paragraph format
eliminates the space above and below, and includes a single tab setting (more about this
in a bit). The last sub-equation is on a line that used the eml EquationMultLast para-
graph format. This provides no space above and provides the normal amount of space
below, and also includes a single tab stop.

Each sub-equation, except the first, should be preceded with a tab character. To line up
the equations properly, I used View→Rulers to display the rulers and then individually
adjust the position of the tab stops. This allows me to visually line up the equations so as
to convey the proper nesting. You can do this simply by selecting the arrows on the ruler
that denote the tab stops and simply dragging them either left or right until the sub-equa-
tion properly lines up with the one above it.

6 Floating Objects
With FrameMaker, tables are used for any floating objects that need a caption. This
includes tables, figures and listings. You insert tables by selecting Insert Table from the
table menu, and then specify type of object you want in the Table Format field.

Captions. Captions should be complete sentences, preferably a single sentence that is
contained on a single line. They should be set in sentence case (only the first word, for-
mal names, and acronyms are capitalized) and should be properly punctuated.

Table Anchors. You delete or move a table by deleting or moving its anchor point.
However, it can sometimes be difficult to find its anchor point. To do so, enable the
viewing of text symbols by selecting View → Text Symbols and look for an upside down
block T. The one associated with Table 1 immediately follows the period at the end of
this sentence. To confirm that the anchor is associated with the right table, drag the
mouse over the anchor while pressing the left mouse button, the desired table should
highlight. You can delete a table by deleting its anchor, you can move the table by cut-
ting and pasting its anchor.
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It is often best to place table anchors at the end of paragraphs so that the table does not
split the paragraph.

6.1 Tables

There is wide variety in tables, and we cannot provide one that will fit everyone’s needs.
When creating tables, try to make them visually appealing. A table with sub-headings is
shown in Table 1. The Table → Custom Ruling and Shading were used to draw (or
erase) the lines. Turn off borders using View → Borders to see what the table will look
like when printed.

You may need to add extra empty columns to the right and left in order to properly cen-
ter the table while still having a full termination line. You may also need an extra empty
row at the end to properly space the termination line from the table itself. This is shown
in Table 1. Effectively, the table that the reader sees is embedded in a larger table that
fills the width of the page.

6.2 Figures

There are two types of figures you can add. One is a
run-in figure. These figures should be fairly small and
do not have captions, so you would not use them for
figures that might need to be referenced from other
parts of your paper. You create run-in figures, as
shown on the right, by inserting an Anchored Frame,
and then placing the figure within it. You can either
draw the figure using the drawing palette (the button
on the right with the right triangle on it), or import a figure using File → Import → File.
When importing files, be sure to specify that they be copied into the document rather

TABLE 1 Time required for a tablet of Alka Selzer to completely dissolve in water.

Temperature Time

Hot Water
116° F 11 s

117° F 13 s

115° F 12 s

Temperate Water
66° F 32 s

66° F 34 s

66° F 37 s

Cold Water
37° F 120 s

32° F 105 s

30° F 120 s

PN

M1 M2
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than being imported by reference. When creating the anchored frame, select Run into
Paragraph and then select which side it should be on.

Most figures will be floating figures. These figures have captions. To insert floating fig-
ures, select Insert Table from the table menu, and then specify Figure for the table for-
mat. This creates a one-cell table with a caption, as shown in Figure 1. Within the table,

you insert an anchored frame to hold the graphics. This time specify that the anchored
frame be placed at the insertion point with a 0 distance above baseline. Now add the
graphics to the frame as before. Be sure to add a caption and a reference to the figure
within the text. More about this later.

I have placed a collection of potentially useful schematic symbols in Figure 2 that you
can copy and paste into your schematics. The symbols should be on the grid. Most sym-
bols include an invisible square that makes it easy to realign the symbols to the grid. If
you have View→Borders set the boundary of these squares are shown using dashed
lines. Those borders are not visible when printing of if View→Borders is not set. They
also include white background in the appropriate places to make it easy to wire the sym-
bols by routing the wires underneath them.

FIGURE 1 Capacitance as a function of voltage.

FIGURE 2 Useful schematic symbols.

C0

C0 + C1

C0 – C1

v0

2v1

C

v

P
CxRx CxRx Lx Lx

Out
In IO

IO
N NOut

In IO
IO
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One issue with Framemaker is that if you resize the frame that contains a drawing such
as a schematic, it can cause the objects to no longer fall on the grid. If this occurs, sim-
ple select an object in the drawing, type cntl-A to expand the selection to include all the
objects, and then drag them until they snap on to the grid (this assumes that Graphics→
Snap is enabled). This works as long as every object will naturally align to the same
grid. If some of the objects were off grid before the grid was changed, then it is hard get
the objects that should be on the grid back on to the grid. This is often the case with text
labels on schematics, where the schematic symbols want to be on the grid, but the labels
do not. If you select both the symbols and the labels, you will not be able to drag them
onto the grid. This problem can be avoided by encapsulating the labels within invisible
boxes that align with the grid. To encapsulate a label it should be completely within the
box, and the label and the box should be grouped.

A typical schematic is shown in Figure 3 to illustrate schematic drawing conventions.

If you need to graph measured data, such as waveforms, transfer functions, etc., you can
download a unix program from www.designers-guide.org/submissions.html that will
allow you to create graphs that can be imported into FrameMaker and edited. An exam-
ple of this is shown in Figure 4. The program is called xgraph. It takes a file of xy pairs
and plots them. It has been enhanced to generate a MIF (Maker Interchange Format) file
of the plot though its hardcopy facility, which can be imported into FrameMaker. Once

FIGURE 3 A typical schematic.

FIGURE 2 Useful schematic symbols.

S&HADC ÷N

NP
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imported, you can ungroup the figure and modify as you wish. That was done with
Figure 4, where the axis labels were enhanced, and asymptotes and labels added. Alter-
natively you can use Gnuplot (www.gnuplot.info) and set the output type to mif. 

6.3 Listings

Listings are used to hold code. An example of a listing is shown in Listing 1. It is Ver-
ilog-A model of a varactor. A listing typically contains two paragraph styles, co Code,
and cif CodeFirst. The two styles are the same, except that cif CodeFirst adds a small
amount of space above it. You should use this space to separate out logically distinct
sections of the code. Comments should be italicized.

Both of the code styles support tabs every 0.25 inch. However, tabs entered within
tables cause FrameMaker to step to the next cell in the table, which is not what is

FIGURE 4 Modeled impedance of an RF inductor separated into real (R) and imaginary (X) parts.

LISTING 1 Varactor model.

`include “discipline.h”

module varactor(p, n);
inout p, n;
electrical p, n;
parameter real c0 = 1p from (0:inf); // nominal capacitance
parameter real c1 = 0.5p from [0:c0);
parameter real v0 = 0;
parameter real v1 = 1 from (0:inf);
real q, v;

analog begin
v = V(p,n);
q = c0∗v + c1∗v1∗ln(cosh((v – v0)/v1));
I(p,n) <+ ddt(q);

end
endmodule

Coilcraft A01T Mini Spring

1 mΩ

10 mΩ

100 mΩ

1 Ω

10 Ω

100 Ω

1 kΩ

10 kHz 100 kHz 1 MHz 10 MHz 100 MHz 1 GHz 10 GHz 100 GHz

X

R

Rp

Rs

2πfL1/(2πfCp)

f
2H2
----------
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desired in this case. To indent code in a listing, either copy a tab and repeatedly paste it
before the line, or type Esc Tab.

If possible, try to keep listings to a page or less. However, if needed you can create a
listing that spans more than one page by inserting multiple rows in a listing. Recall that
a listing is a table that contains one cell. Click in that cell and use Table → Add Rows or
Columns to add more rows to the table; Framemaker will then be able to break the list-
ing between the rows. This idea is shown in Listing 2. When creating listings that span
multiple pages, divide the listing between the rows so as to completely fill the all but the
last page. 

For code fragments, you will probably want to have the listings embedded in the text. In
this case, use the ci CodeInline and cif CodeInlineFirst paragraph styles directly in the
text. For example, the heart of Listing 2 is

v = V(p,n);
q = c0∗v + c1∗v1∗ln(cosh((v – v0)/v1));
I(p,n) <+ ddt(q);

When referring to code from within a paragraph, use the Code font from the font library.
For example, here is a reference to ddt(q).

When creating listings, you should to treat multiplication and subtraction symbols as
being special. If you use a simple asterisk for multiplication, it will look like this x*y.
Instead, it is better to use the symbol version of the asterisk, to get x∗y. To get a symbol
version, simply type an asterisk, then select it, access the font catalog (the f button on
the right), and then select Symbol. To type a minus sign, do not use a simple dash, which
ends up looking like x - y. Instead, use a true minus sign, which is accessed using Ctrl Q
Shift P, doing so results in x – y. To avoid having Framemaker put a line break between
a minus sign and a number, go to Format→Document→Text Options ... and remove \=
from the Allow Line Breaks After: field if it is present.

7 Symbols
Table 2 contains a collection of symbols that might be useful for copying and pasting. In
addition, Table 3 contains directions on how to access various types of spaces. 

To create a ‘much greater than’ or ‘much smaller than’ sign, use two greater than or less
than signs, but adjust the spread on the first to –30% (the spread is specified using the
character designer, which is accessed using the button on the right side of the document
window that is labeled with a script f ). This gives either << or >>.

8 References
Never refer directly to the identification number of an object (equation, figure, citation,
etc.). These numbers will change as additional material is added to your paper. Instead,
use cross references. To add a cross reference, use Special → Cross-Reference. This
brings up a form that allows you to chose the object you would like to reference. Begin
by assuring that the Document is Current, and the Source Type is Paragraphs. Then,
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LISTING 2 Quadrature Differential VCO model that includes FM jitter.

// Quadrature Differential VCO with Jitter

// The model starts by calculating the gain and then converting the input to frequency.
// Then the frequency is bounded to fall within Fmin and Fmax.
// This is optional, if not desired, simply comment out this section of the model.
// The frequency is dithered to account for phase noise (dT comes from a previous step)
// The frequency is converted to phase by integrating, modulo 2π
// Finally the phase is partitioned into four bins, and the output changes when the phase
// transitions from one bin to another. Transition also causes new dT to be generated.

‘include “discipline.h”
‘include “constants.h”

module quadVco (PIout,NIout, PQout,NQout, Pin,Nin);

electrical PIout, NIout, PQout, NQout, Pin, Nin;
output PIout, NIout, PQout, NQout; input Pin, Nin;

parameter real Vmin=0;
parameter real Vmax=Vmin+1 from (Vmin:inf);
parameter real Fmin=1 from (0:inf);
parameter real Fmax=2∗Fmin from (Fmin:inf);
parameter real Vlo=–1, Vhi=1;
parameter real jitter=0 from [0:0.25/Fmax);
parameter real ttol=1u/Fmax from (0:1/Fmax);
parameter real tt=0.01/Fmax;

real freq, phase, dT, Iout, Qout;
integer i, q, seed;

analog begin
@(initial_step) seed = 133;

// compute the freq from the input voltage
freq = (V(Pin,Nin) − Vmin) ∗ (Fmax − Fmin) / (Vmax − Vmin) + Fmin;

// bound the frequency (this is optional)
if (freq > Fmax) freq = Fmax;
if (freq < Fmin) freq = Fmin;

// add the phase noise
freq = freq/(1 + dT∗freq);

// phase is the integral of the freq modulo 2π
phase = 2∗‘M_PI∗idtmod(freq, 0.0, 1.0, –0.5);

// update jitter where phase crosses π/2
// 2=sqrt(K), K=4 jitter updates per period
@(cross(phase – 3∗‘M_PI/4, +1, ttol) or
   cross(phase – ‘M_PI/4, +1, ttol) or
   cross(phase + ‘M_PI/4, +1, ttol) or
   cross(phase + 3∗‘M_PI/4, +1, ttol)) begin

dT = 2∗jitter∗$dist_normal(seed,0,1);
i = (phase >= –3∗‘M_PI/4) && (phase < ‘M_PI/4);
q = (phase >= –‘M_PI/4) && (phase < 3∗‘M_PI/4);

end
Continued on next page.
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specify the Paragraph Tag of the object to be referenced and select the specific object
from the list of Paragraphs. Finally, choose the appropriate Format.

As you make changes to your paper, the cross references may go out of date. This is
generally not a problem because they are automatically updated if you save or print the
document. However, at times it can become confusing. To manually update the cross
references, use Edit → Update References and choose All Cross References.

Occasionally you may delete a target of a cross reference. When you go to update the
references FrameMaker will warn you about one or more unresolved cross-references.
In this situation search for and repair the references. To do so, use Edit → Find/Change.
In the Find section of the form, choose Unresolved Cross-Reference. Once you find the
reference, open it by double-clicking it. Then, change the Source Type from Cross-Ref-
erence Markers to Paragraph Tags and then specify a new target.

Tables, Figures, Listings, and Sections. Consider referencing Table 3. In this case,
the Paragraph Tag would be set to tc TableCaption and, since the table is close by, the
Format would be set to Table Number. If we were referring to Table 1 on page 8, the
format would be set to Table Number & Page to give the reader some help finding the
table.

One references figures and listings in a manner similar to tables.

Equations. There are two basic types of equation references. Normally one uses a for-
mat of Eqn to reference an equation. This format places the equation number within
parentheses, as in the following reference to (2). However this is a bit awkward to use at
the beginning of a sentence. In this case, set the format to Equation. Equation 2 uses this
format. Finally, if the equation is a long ways away, consider using a format of Equation
& Page, which results in Equation 2 on page 6.

Bibliographic Citations. When referencing bibliographic citations, always use a for-
mat of BibCitation regardless of how far it is to the citation. For example, [1]. If citing
several reference in the same place, combine them. In this case, you would not use the
BibCitation format. Rather, you construct the citation manually. Type in the brackets,
then individually add the references separated by commas. Each would use the Number
Only format. For example, here is a collection of AMS references [2, 3, 4].

Continuing from previous page.

// Generate I and Q outputs
V(PIout) <+ transition(i ? Vhi : Vlo, 0, tt);
V(NIout) <+ transition(i ? Vlo : Vhi, 0, tt);
V(PQout) <+ transition(q ? Vhi : Vlo, 0, tt);
V(NQout) <+ transition(q ? Vlo : Vhi, 0, tt);

end
endmodule

LISTING 2 Quadrature Differential VCO model that includes FM jitter.
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TABLE 2 A useful collection of symbols.

Text Symbol
Shift ^Q Shift 

^Q
Shift ^Q Shift 

^Q
a A · ¡ α Α 〈 ℑ
b B ‚ ¬ β Β ® ℜ
c C „ Ð χ Χ © ℘
d D ‰ ƒ δ Δ ™ ⊗
e E Â Ý ε Ε ∑ ⊕
f F Ê ý φ Φ ⎛ ∅
g G Á « γ Γ ⎜ ∩
h H Ë » η Η ⎝ ∪
i I È … ι Ι ⎡ ⊃
j J Í þ ϕ ϑ ⎢ ⊇
k K Î À κ Κ ⎣ ⊄
l L Ï Ã λ Λ ⎧ ⊂

m M Ì Õ μ Μ ⎨ ⊆
n N Ó Œ ν Ν ⎩ ∈
o O Ô œ ο Ο ⎪ ∉
p P š – π Π � ∠
q Q Ò — θ Θ 〉 ∇
r R Ú “ ρ Ρ ∫ ®
s S Û ” σ Σ ⌠ ©
t T Ù ‘ τ Τ ⎮ ™
u U € ’ υ Υ ⌡ ∏
v V ˆ ÷ ϖ ς ⎞ √
w W ˜ Þ ω Ω ⎟ ⋅
x X ¯ ÿ ξ Ξ ⎠ ¬
y Y  Ÿ ψ Ψ ⎤ ∧
z Z Ž ⁄ ζ Ζ ⎥ ∨
1 ! ± ° 1 ! ± ϒ
2 @ ð ¿ 2 ≅ ″ ℵ
3 # Š £ 3 # ≥ ≤
4 $ ¥ § 4 ∃ × ⁄
5 % µ • 5 % ∝ ∞
6 ^ ¹ ? 6 ⊥ ∂ ⇒
7 & ² ¶ 7 & • ƒ
8 * ³ ™ 8 ∗ ÷ ♠
9 ( ¼ ® 9 ( ≠ ♦
0 ) × © 0 ) ° ♥
- _ ¦ ? − _ ↑ ⇓
= + ¾ ´ = + ⏐ ↔
‘ ~ ‡ ž ™ ∼ ◊ ⎭
[ { ¤ ° [ { ⇔ ⎦
] } › ″ ] } ⇑ ⎬
\ | ‹ ¸ ∴ | ⇐ ⎫
; : ª ½ ; : ≈ ≡
‘ “ ß ¢ ™ ® ♣ ′
, < ¨ º , < ← …
. > Æ æ . > → ⎯
/ ? Ø ø / ? ↓ ↵
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9 Hypertext Links
When mentioning a website, you should add a hypertext link to that website. To do so,
select the reference to the website, and use Special → Hypertext to bring up the hyper-
text menu. Set the command to Go to URL. FrameMaker will then add the message URL
to the text entry box. Add a the path to the website after this text while following exam-
ple given on the form. So for example, if you wanted to reference www.designers-
guide.org, you would enter http://www.designers-guide.org. Then click New Hypertext
Marker. To edit a hypertext marker, use View → Text Symbols to see the marker’s identi-
fying symbol. It looks like a block T. Bring up the hypertext menu and then select this
symbol to see and edit the details of the marker.

10 Change Bars
During the editing process, it is helpful to enable change bars. To do so in FrameMaker,
use Format → Document → Change Bars to enable or reset the change bars. In addi-
tion, there are two entries in the font catalog (accessible with the f button on the right),
Changed and Unchanged that can be applied to text in order to either activate or clear
the change bar for that text.

11 Footnotes
To add footnotes, place the cursor where you want the reference to the footnote, and use
Special → Footnote.1

12 Conclusion
It is a good idea to add the following “if you have questions” paragraph to the end of
your paper.

12.1 If You Have Questions

If you have questions about what you have just read, feel free to post them on the Forum
section of The Designer’s Guide Community website. Do so by going to www.designers-
guide.org/Forum.

TABLE 3 Spaces.

em en numeric thin non-breaking

esc-space-m esc-space-n esc-space-1 esc-space-t ctrl-space

1. A footnote looks like this.
This is the second paragraph of the same footnote.
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Appendix A Editing
This section was formatted as an appendix simply as an example.

Papers are published as is, without editing. So it is very important that you to do a very
careful job of editing your document before submitting it. Of course the first thing is to
use FrameMaker’s spell checker to catch the first-order errors. Microsoft Word has a
more sophisticated grammar checker. I have been known to use this by first entering a
draft of the text into Word, correcting the spelling and grammar errors it finds, and
transferring the text into FrameMaker. Another helpful thing to do is to use text-to-
speech software and have the computer read your writing to you a paragraph at a time. It
is surprising how many mistakes you will find this way, even in a paragraph that you
have already carefully edited. There are several commercial text-to-speech engines
available. A free one is available from www.readplease.com.

A.1 Read It Again

Finally, once you have completed and carefully edited your paper, put it aside for a few
days to a week. Then read it again and carefully look for more errors.

References
Notice that the References section is not numbered.

When giving references, it is best to give those that would be most helpful to the reader.
Thus, give references that are easily found, that will be around for a long time, that have
the most useful information, that are clearest and easiest to read, and that are correct.
Avoid references to articles in non-archival magazines. Also, avoid references that
would be included solely to acknowledge the original source of an idea, especially if the
original source is hard to find, difficult to read, or does not contain much information. 

When citing material, try to follow the examples given below. When referring to a web-
site, make the name of the website a hypertext link (See “Hypertext Links” on page 16).

[1] K. S. Kundert. The Designer’s Guide to SPICE and Spectre. Kluwer Academic
Publishers, 1995.

[2] E. Christen, K. Bakalar. VHDL-AMS — a hardware description language for ana-
log and mixed-signal applications. IEEE Transactions on Circuits and Systems II:
Analog and Digital Signal Processing, vol. 46, no. 10, Oct. 1999, pp. 1263-1272. 

[3] Definitions of Analog and Mixed-Signal Extensions to IEEE Standard VHDL. IEEE
Standard 1076.1-1999.

[4] Verilog-AMS Language Reference Manual: Analog & Mixed-Signal Extensions to
Verilog HDL, version 2.0. Open Verilog International, 2000. Available from
www.eda.org/verilog-ams.

[5] The Designer’s Guide, www.designers-guide.org.

[6] Ken Kundert. A test bench for differential circuits. www.designers-guide.org/Anal-
ysis.
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