The Designer's Guide Community
Forum
Welcome, Guest. Please Login or Register. Please follow the Forum guidelines.
Jul 18th, 2019, 8:38pm
Pages: 1
Send Topic Print
wreal net has multiple non-Z drivers (Read 536 times)
arupkg
New Member
*
Offline



Posts: 9
Singapore
wreal net has multiple non-Z drivers
Sep 24th, 2018, 5:03pm
 
Hi All,

   I have a VerilogAMS model where I the supply and ground is specified as wreal.  I use the functional model of an inverter to provide a clock from a "vpulse" in analogLib to the above mentioned VerilogAMS model. The power supplies to both the VerilogAMS model and the functional model of the inverter are provided from a "vdc". However I get the ncsim warnings

vdd: wreal net has multiple non-Z drivers (Time: 0 FS + 1).
vss: wreal net has multiple non-Z drivers (Time: 0 FS + 1)

and the inverter functional model output is X. Is it illegal to define a vdd and vss as wreal? If not, what would be a solution for this? Please let me know if any more information is needed.
Back to top
 
 
View Profile   IP Logged
Andrew Beckett
Senior Fellow
******
Offline

Life, don't talk to
me about Life...

Posts: 1708
Bracknell, UK
Re: wreal net has multiple non-Z drivers
Reply #1 - Oct 21st, 2018, 4:49am
 
Having the supplies as wreal shouldn't be a problem - the message suggests that you are setting the wreal value on these nets in more than one place - and that's causing the problem.

Without more detail on the circuit configuration and what the models look like, plus which simulator you're using, it's going to be hard to pinpoint it from afar... perhaps you should contact the simulator vendor's support site?

Regards,

Andrew.
Back to top
 
 
View Profile WWW   IP Logged
Pages: 1
Send Topic Print
Copyright 2002-2019 Designer’s Guide Consulting, Inc. Designer’s Guide® is a registered trademark of Designer’s Guide Consulting, Inc. All rights reserved. Send comments or questions to editor@designers-guide.org. Consider submitting a paper or model.