The Designer's Guide Community
Forum
Welcome, Guest. Please Login or Register. Please follow the Forum guidelines.
May 25th, 2019, 3:11am
Pages: 1
Send Topic Print
AMS simulation error (Read 2724 times)
AMS_ei
Community Member
***
Offline



Posts: 67

AMS simulation error
Jul 13th, 2016, 6:13am
 
Hi,
I am a new in this ams designer.

In my design there are two power domains. One is 1.8V supply (vdd) and the other one 1.24V regulator output (dvddao).
I have created the two sets of connect rules  CR_dynsup_full_fast_macau_dvdd and  CR_dynsup_full_fast_macau_vdd. These connect rules are using the connect modules from the cadence precompiled libraries.

I am successfully able to compile them and used in AMS simulation. After the elboration stage is complete, when Ultrasim is just about to start, it is showing me the following error:

ERROR: “esimPublisher/esimDbPublisher.cc” 7584 internal error

Here is the amscf.scs file that I've used in my simulation

In the amscf.scs file:

amsd{
       
        ie connrules=CR_dynsup_full_fast_macau_dvdd discipline=logic1v24 inst=“tb_top.dut.Icore_top.Idigital_top” net=“tb_top.chip_top_dvddao”

       ie connrules=CR_dynsup_full_fast_macau_vdd vddnet=“tb_top.dut.vdd” vssnet=“tb_top.dut.dvss” rout=0.001 vmax=3.6 discipline=logic1v8

        }

Below are the irun options that I've passed in the simulation.

irun command lines options are:
   -amsconrules  CR_dynsup_full_fast_macau_dvdd -amsconnrules  CR_dynsup_full_fast_macau_vdd

irun version: INCISIV15.10.005

Could anyone please guide me how to resolve this issue?

Thank you.
Back to top
 
 
View Profile   IP Logged
Ken Kundert
Global Moderator
*****
Offline



Posts: 2166
Silicon Valley
Re: AMS simulation error
Reply #1 - Jul 13th, 2016, 10:58am
 
By definition internal errors are simulator errors not user errors. So you should definitely be talking to Cadence about this.

As a work around, you might try using the Spectre engine rather than the Ultrasim engine.

-Ken
Back to top
 
 
View Profile WWW   IP Logged
AMS_ei
Community Member
***
Offline



Posts: 67

Re: AMS simulation error
Reply #2 - Jul 30th, 2016, 7:45am
 
Hi Ken,

I really appreciate your answer in this.
In actuality, I am running with full chip simulation. Spectre will take long time for simulation at the full chip level.

Is there any way that the simulation speed can be significantly improved without sacrificing its accuracy?

"reltol" may do that but it will sacrifice accuracy with improvement in speed. I am not sure of this.

Could you please explain me here how spectre could be used as a full chip simulator like Ultrasim?

Thank you
Back to top
 
 
View Profile   IP Logged
Pages: 1
Send Topic Print
Copyright 2002-2019 Designer’s Guide Consulting, Inc. Designer’s Guide® is a registered trademark of Designer’s Guide Consulting, Inc. All rights reserved. Send comments or questions to editor@designers-guide.org. Consider submitting a paper or model.