The Designer's Guide Community
Forum
Welcome, Guest. Please Login or Register. Please follow the Forum guidelines.
Oct 14th, 2019, 2:17pm
Pages: 1
Send Topic Print
+UVM_TestNAME argument makes cadence virtuoso crash (IC_617_700) (Read 2064 times)
gp_ei
New Member
*
Offline



Posts: 2

+UVM_TestNAME argument makes cadence virtuoso crash (IC_617_700)
Jun 6th, 2017, 5:14am
 
Hi,

I am using cadence incisive 15.20.014 as digital simulator and virtuoso verson IC_617_700.

For my test env i am using gui based approach.From ADE L i am using  --> simulation --> option -->AMS SIMULATOR.

Inside Main tab there is one raw called "Additional arguments"
I am passing -uvm +UVM_TESTNAME=<test_name> argument.

When i starts simulation using netlist and run tool gets crashed with FATAL.

Can any one provide me the solution to pass UVM_TESTNAME from command line in GUI based approach?
Back to top
 
« Last Edit: Jun 06th, 2017, 6:19am by gp_ei »  
View Profile   IP Logged
Andrew Beckett
Senior Fellow
******
Offline

Life, don't talk to
me about Life...

Posts: 1713
Bracknell, UK
Re: +UVM_TestNAME argument makes cadence virtuoso crash (IC_617_700)
Reply #1 - Jun 6th, 2017, 11:44am
 
I found a sort-of similar report of a crash which looks like this - however, there wasn't much information to go on.

I suggest you first try seeing if you can use the latest hotfix of INCISIVE152 - and if it still crashes, contact http://support.cadence.com

Regards,

Andrew.
Back to top
 
 
View Profile WWW   IP Logged
gp_ei
New Member
*
Offline



Posts: 2

Re: +UVM_TestNAME argument makes cadence virtuoso crash (IC_617_700)
Reply #2 - Jun 6th, 2017, 10:20pm
 
Thanks Andrew,

Between you were using GUI based approach in which you have faced crash issue?

Because with same cadence version it is running fine in bash mode(Command Line) approach
Back to top
 
 
View Profile   IP Logged
Andrew Beckett
Senior Fellow
******
Offline

Life, don't talk to
me about Life...

Posts: 1713
Bracknell, UK
Re: +UVM_TestNAME argument makes cadence virtuoso crash (IC_617_700)
Reply #3 - Jul 25th, 2017, 9:19am
 
I didn't hit the issue myself - I just found a report of a sort-of similar crash. However, there was very little detail on what the setup or issue was.

Andrew.
Back to top
 
 
View Profile WWW   IP Logged
Pages: 1
Send Topic Print
Copyright 2002-2019 Designer’s Guide Consulting, Inc. Designer’s Guide® is a registered trademark of Designer’s Guide Consulting, Inc. All rights reserved. Send comments or questions to editor@designers-guide.org. Consider submitting a paper or model.