The Designer's Guide Community
Forum
Welcome, Guest. Please Login or Register. Please follow the Forum guidelines.
Jul 16th, 2019, 1:57pm
Pages: 1
Send Topic Print
hAMSter Model Editor Error Messages (Read 1620 times)
loumbut5
New Member
*
Offline



Posts: 6
Kenya
hAMSter Model Editor Error Messages
Jul 21st, 2017, 9:18am
 
Hi, sorry for the ambiguous topic but I have just started coding VHDL-AMS today. Smiley
Anyways, I am encountering the following errors while compiling and simulating my code which I am manually translating from SPICE to link with VHDL. Cool

Error : Cannot save/load file "C:\Program Files\Hamster\Lib\\ieee\electrical_systems_pack\electrical_systems.package_bin"
Error : Library "spice2vhd" not found

The first error is beyond me. I don't know what the compiler wants. My directory only goes to C:\Program Files\Hamster\LIB\ieee\ with no electrical_systems_pack directory in the installation.
The second one is confusing since in the LIB directory, I have added the SPICE2VHD file attached.
Though I am not sure if I have saved it correctly since it is two packages in one. Roll Eyes
If you happen to know how to assist, please do. Smiley
Back to top
 
View Profile loumbut51   IP Logged
loumbut5
New Member
*
Offline



Posts: 6
Kenya
Re: hAMSter Model Editor Error Messages
Reply #1 - Jul 23rd, 2017, 10:13am
 
Ok, I found the problem, I was not loading the proper library.
The new error now is:

\QU2.vhd( 4,???) : Error : Library "spice2vhd" not found
\QU2.vhd( 11,ENTITY qu2) : Info : Entity/Package "qu2" overwritten
\QU2.vhd( 8,ENTITY qu2) : Error : Library "spice2vhd" not found
\QU2.vhd( 9,ENTITY qu2) : Error : Library "spice2vhd" not found
\QU2.vhd( 14,ENTITY qu2) : Error : Simulation object for entity qu2 not created because of 2 errors
\QU2.vhd(???,?] : Error 70015 : error with compiling Undecided

From the code:

library IEEE, SPICE2VHD;                                  
use IEEE.ELECTRICAL_SYSTEMS.all;  
use ieee.std_logic_1164.all;
use ieee.math_real.all;
use SPICE2VHD.SPICE_PARAMETERS.all;
use SPICE2VHD.SPICE_COMPONENTS.all;

Please assist.
Regards.
Back to top
 
 
View Profile loumbut51   IP Logged
loumbut5
New Member
*
Offline



Posts: 6
Kenya
Re: hAMSter Model Editor Error Messages
Reply #2 - Jul 25th, 2017, 9:42am
 
Ok, had to recode the whole thing so as not to need the unrecognized library. Tongue
Oh well, it works now. Smiley
Back to top
 
 
View Profile loumbut51   IP Logged
Geoffrey_Coram
Senior Fellow
******
Offline



Posts: 1964
Massachusetts, USA
Re: hAMSter Model Editor Error Messages
Reply #3 - Aug 7th, 2017, 6:24am
 
Since you did not post your netlist (at least, you indicated you only posted the library), we have no idea how you tried to include that library. Even someone who has used Hamster before would only be guessing.
Back to top
 
 

If at first you do succeed, STOP, raise your standards, and stop wasting your time.
View Profile WWW   IP Logged
Pages: 1
Send Topic Print
Copyright 2002-2019 Designer’s Guide Consulting, Inc. Designer’s Guide® is a registered trademark of Designer’s Guide Consulting, Inc. All rights reserved. Send comments or questions to editor@designers-guide.org. Consider submitting a paper or model.