The Designer's Guide Community
Forum
Welcome, Guest. Please Login or Register. Please follow the Forum guidelines.
May 21st, 2019, 5:52pm
Pages: 1
Send Topic Print
Issue with Cadence analog value fetch functions (Read 1456 times)
sgh2050
New Member
*
Offline



Posts: 2

Issue with Cadence analog value fetch functions
Sep 21st, 2017, 6:18am
 
Hi All,

Cadence provides following analog value fetch functions
$cds_analog_is_valid()
$cds_get_analog_value()

I have these functions in a SystemVerilog module.

I am using $cds_analog_is_valid  first to check a signal is a analog signal and then $cds_get_analog_value to get it as real number. When i use these functions I get the error message.


ncsim: *E, MSSYSTF ..... User Defined system task or function ($cds_analog_is_valid) registered during elaboration and used within the simulation has not been registered during simulation

ncsim: *E, MSSYSTF ..... User Defined system task or function ($cds_get_analog_value) registered during elaboration and used within the simulation has not been registered during simulation


Let me know if you have faced similar issue and how you solved it.
I guess Cadence VPI routines with these functions is not getting loaded. Is there a way, I can load these these using -loadvpi *

BR & TIA
Back to top
 
 
View Profile   IP Logged
Andrew Beckett
Senior Fellow
******
Offline

Life, don't talk to
me about Life...

Posts: 1708
Bracknell, UK
Re: Issue with Cadence analog value fetch functions
Reply #1 - Dec 21st, 2017, 7:43am
 
You should not need to use -loadvpi. I suspect you're probably using an old version of the simulator maybe? What version are you using? (what does "irun -version" return).

Regards,

Andrew.
Back to top
 
 
View Profile WWW   IP Logged
Pages: 1
Send Topic Print
Copyright 2002-2019 Designer’s Guide Consulting, Inc. Designer’s Guide® is a registered trademark of Designer’s Guide Consulting, Inc. All rights reserved. Send comments or questions to editor@designers-guide.org. Consider submitting a paper or model.