The Designer's Guide Community
Forum
Welcome, Guest. Please Login or Register. Please follow the Forum guidelines.
May 25th, 2019, 5:52pm
Pages: 1
Send Topic Print
Verilog AMS (Read 38 times)
Vivek Saurabh
New Member
*
Offline



Posts: 2

Verilog AMS
May 10th, 2019, 10:44pm
 
Hi.

I have been trying to carry out mixed mode AMS simulation. For the schematic, I chose a verilog coded or gate, whose output is connected to veriloga coded xor gate and xor output goes to analog inverter (one using nmos and pmos).

At two inputs of Verilog OR Gate I give two different vpulse with V0 as 0.85V and V1 as 0V and tr tf period as required. I am using connectlib ConnectRules18Vfullfast as interface.
XOR gate and Inverters are working as expected but verilog coded OR gate is not showing any transition at output. It is always at level 0. When I replace OR with verilog Inverter in same schematic, it all works fine.

What could be the reason, how do I get correct output from verilog OR? Is there something to do with connec rules?

Image shows the case where 1st and 2nd waveform is input to OR and third waveform is output which doesnt show any transition.
Back to top
 

Screenshot_from_2019-05-09_133821.png
View Profile   IP Logged
Pages: 1
Send Topic Print
Copyright 2002-2019 Designer’s Guide Consulting, Inc. Designer’s Guide® is a registered trademark of Designer’s Guide Consulting, Inc. All rights reserved. Send comments or questions to editor@designers-guide.org. Consider submitting a paper or model.